BUG: garbage left in memory when processing multiple IFC files in Blender, one after another?

Hey all!
I've been processing IFC models in Blender 3.3 using the BlenderBIM for visualization purposes. Suddenly, I started getting error messages from BlenderBIM saying that "instance #nnn is not found" when trying to read IFC data from a file. I checked the IFC files in question and the instances were indeed in those files after all. I tried updating the whole setup to Blender 4.1 and the latest BlenderBIM addon, hoping that it might solve the problem (I really didn't want to try and debug BlenderBIM / IfcOpenShell..), and first it seemed to do the trick, but then I bumped into the same problem again after a while.
I took me a few hours of debugging until I noticed by accident that the problem was solved by closing Blender and restarting it again, and only then open the IFC file or a Blender scene containing the IFC model for processing. No more error messages. You see, I had been processing Blender scenes one after another without closing Blender in between the files.
To me, this looks like there must be some garbage hanging in the memory from the previous file / scene when you open another Blender scene or start a new scene and load an IFC model in it. And the same problem is still present in the latest Blender / BlenderBIM setup. I'm not quite sure (nor am I capable of verifying it) which one is actually causing the problem, Blender or BlenderBIM, but I'd suspect it's probably BlenderBIM leaving something behind which causes it to fail when reading data from an IFC file. Maybe someone involved in the BlenderBIM development could have a look at this?
And please, feel free to re-phrase the title if need be. :)

Sign In or Register to comment.