Blender Plan View Display Issue

I am having an issue in a Blender model where in Top Orthographic View Solid Mode the z value of objects is jumbled for example my roof is shown under my floor in Top Perspective View Solid Mode things look great.

Is this kind of question appropriate for this forum? If not should I be asking this on stack exchange? I am not sure if this is part of the probelm but this model is from a lot of sources: An IFC from revit imported with BlenderBIM some time ago, terrain from QGIS, and 2D plants from CAD converted to 3d obects in Blender, and meshes created in Blender.


  • Have you checked your view clipping settings in the N menu?

  • Interesting that worked.
    The Clip end I guess was set too high. It seems like somewhere between 100,000ft and 1,000,000ft things get weird.

  • Yeah calculation with extreme numbers makes computers sad :)

Sign In or Register to comment.