BlenderBIM Add-on: IFC Export Not Visible In Revit

edited March 17 in General


Hi
When I try to export a simple cube from Blender to IFC I find that I can't see anything show up in Revit 2021. Have I set something incorrectly? It does show up in BIMVision.
Thanks

Comments

  • Sharing the Blend file is not sufficient - you will also need to share the IFC file. Two initial guesses, which I won't know for certain until I see the IFC:

    1. Maybe Revit doesn't support importing IfcBuildingElementPart classes? This may be solved by using a different class.
    2. Maybe you are exporting an IFC4, and the particular version you are using of the IFC link add-on in Revit doesn't support IFC4 tessellations? This may be solved either by exporting to IFC2X3, or enabling the "Force faceted brep" vendor workaround and updating the mesh.
  • Here's the IFC file. I have tried to change the IFC category to IfcPipeFitting which should show up in Revit 2021....

  • edited March 11

    @Bedson your IFC file seems to be empty. This suggests that you were not exporting it correctly. Be sure to update the mesh representation with Shift-E.

    I created a new project and assigned it to an IfcPipeFitting, and made it a faceted brep. It seems to come through in Revit without issues.

    Issues that you might've encountered:

    • It seemed that IfcBuildingElementPart didn't want to import in Revit in the version I had (which is outdated, YMMV), either because it's yet another Revit bug or perhaps because it was standalone which is not very common for an element part (and perhaps disallowed, I should check).
    • My Revit version didn't like tessellations, so I had to force a faceted brep. I'm pretty sure that they've fixed this in the latest Revit version, so you shouldn't run into this issue, but just in case I thought I'd mention it.
    • Your mesh was not clean. You should merge duplicate vertices to clean it up, otherwise Revit can't handle it.

    I've attached the working IFC for your reference.

  • edited March 11

    Hi @Moult
    I tried Shift+E then selected to update the Mesh Representation but received the following error:

  • I also tried to uninstall BlenderBIM as I thought there might be an installation problem but I received the following error:

  • @Moult the IFC file you posted loaded perfectly into Revit

  • You're running into these issues because the new workflow requires you to keep the Blender file and the IFC in sync. This may help explain: https://github.com/IfcOpenShell/IfcOpenShell/issues/1360#issuecomment-792353349 - when these are no longer in sync, you run into these issues. I believe the best solution is for me to fix these usability issues first, and then try again from scratch - instead of attempting to teach people a workflow that would shortly become obsolete.

    The uninstall issue is an upstream Blender bug. You have to first disable the add-on, then restart Blender, and then remove the add-on. I have written some instructions for this in the add-on preferences so future users will uninstall it properly and avoid that bug.

  • Regarding current IFC WorkFlow
    Does this imply that when creating a new design from scratch, the easiest workflow would be to delete IFC file and create a new one?

  • @CadGiru what it means is that firstly any projects you were working on prior to the refactor will not be compatible with the post-refactor BlenderBIM Add-on. It also means that until these bugs are fixed, I would not advise people attempting to use the BlenderBIM Add-on for "let's author a BIM project from scratch". I wish it didn't have to be that way, but with the current resources and alpha state of the software, that's the way things are. I will prioritise this to fix, and hopefully collaborate with @condur to create some new tutorials on the new state of things.

  • Hi @Moult
    I have uninstalled BlenderBIM by first 'Unticking' the add-on then restarting Blender then used the 'Remove' button.
    Next I installed the BlenderBIM add-on onto Blender 2.92 (I'm using Windows 10). I don't seem to be able to change the IFC classification anymore:

  • Unless you create an IfcProject first, you will not see it.

  • @Moult said:
    what it means is that firstly any projects you were working on prior to the refactor will not be compatible with the post-refactor BlenderBIM Add-on

    I guess by projects you mean blender files right?

  • @Jesusbill yes, Blender files. Also yes, correct, an IfcProject needs to exist before you can do any BIM operations.

  • Excellent - the 'Create Project' button works nicely. Despite uninstalling and reinstalling BlenderBIM I still receive an error when using Shift + E > Update Mesh Representation:

  • edited March 16

    @Bedson : Are you using this command after you have created properly an Ifc Element?
    In any case I believe these actions will eventually vanish as they will be integrated in the creation procedure, so don't worry for now.

  • I'm going to wait for the next BlenderBIM update then retry....

  • @Moult @Jesusbill I have now tried with the latest BlenderBIM (blender28-bim-210404-py37-win). I still can't see the blender 2.92 object in Revit 2021.
    I haven't been able to find how to 'force a faceted Brep' in Blender. My Blender and IFC file are attached.

  • Probably installation.

  • I have received some errors when I tried to set the project up as IFC2...

  • @Bedson your object is not in the spatial tree. You need to put your object in the spatial tree (e.g. put it on the ground floor of your building) so that Revit will see it.

    By the way, I did spot a bug related to exporting, which has been fixed. You can pick up the fixed version via the next the Github daily developer build. See https://github.com/IfcOpenShell/IfcOpenShell/commit/c541aa78e50189096361ffcd9d2308b73c98a9d3

    Here is your file in Revit. By the way, always check your phase settings in Revit when linking or opening IFCs - there is a bug in Revit where it may not set the phase correctly.

  • Hi @Moult thank you for your patience on this.
    I have recorded a screencast showing my latest attempt - I'm sure I'm missing an obvious step. The object in Revit appears as a cuboid instead of a stepped element...

    magicalcloud_75
  • edited April 9

    @Bedson ahh, thanks for the detailed recording. You're not missing any step (though you don't need to update the representation anymore :)).

    Based off the video, my best guess is that you are using the IFC add-on that comes shipped with Revit 2021. Unfortunately, the IFC add-on that ships is actually really outdated and has a ton of bugs, and unfortunately there's not much I can do about that - there's nothing wrong with your IFC or with Blender. I know, I know, I know...

    Can you try downloading the latest version of Autodesk's Revit IFC tool here: https://apps.autodesk.com/RVT/en/Detail/Index?id=7265544480016320144 and installing it and trying again?

    Note: the recommendation to upgrade from the Revit shipped version is mentioned in the OSArch Wiki, as often it is the first thing that causes many issues with users: https://wiki.osarch.org/index.php?title=Revit_setup_for_OpenBIM

  • The Revit IFC update worked brilliantly, thanks @Moult !

    MoultJesusbill
Sign In or Register to comment.