Blenderbim crashing when selecting the Bim tool?

Anyone having this experience? I load an IFCType, I click on the tool panel, then click the BIM tool icon and it crashes with no error given.



  • Yes, happened several times before to me as well. can't recreate it because Blender just crashes and closes. I'm on Windows 10.

  • Yes, been trying to consistently recreate as well. Windows10

  • Ok likewise windows 10, I don't have access to a linux machine atm to test it and it's been super inconsistent but it's nearly every time now on a native ifc file, I think it may be crashing while still loading the custom IfcType? I always thought they load super quickly compare to bloody Revit families but maybe we are interrupting the operation? Does that feel the same for you both?

    I'm trying to test it with trial and error but I just installed Blender 3.3 and BlenderBim wont open it at all now haha

  • So I've just had it happen 5 times in a row with the latest Blenderbim-20220916, it just stopped doing it now otherwise I would have recorded.
    it distinctly crashes when I tab the n-panel with the hotkey
    and on reload it has unloaded Blenderbim
    by opening up the n panel with the mouse before I select the BIM tool it seemed to stop and it wasn't crashing anymore

  • Hey, I hadn't seen this thread. This issue might be on me. In any case, I'm working on a refactor of the related code. Let's see if I can submit a PR during this weekend, or early next week.

    In the meantime, can you try to start Blender from the console and see the actual error message when it eventually crashes?

  • edited September 2022

    I haven't experienced any crashes on Linux, but if there is a crash somewhere I think that's a critical bug that will delay the next release, so please make it a high priority to try to recreate so we can squash it :)

    Typical IfcOpenShell crashes occur when an IFC element is being referenced that has been deleted. E.g. x = f.createIfcWall(). f.remove(x), then print(x). However if it's Windows specific then it is may not be that issue.

  • AceAce
    edited September 2022

    Hi @cvillagrasa sorry it took me awhile to figure out how to launch it form the command line but here is the report:

    C:\Users\USER>"C:\Program Files (x86)\Steam\steamapps\common\Blender\blender.exe"
    Read prefs: C:\Users\USER\AppData\Roaming\Blender Foundation\Blender\3.3\config\userpref.blend
    Address : 0x00007FF7601AFC84
    Module : blender.exe
    Thread : 000047d0
    Writing: C:\Users\USER\AppData\Local\Temp\blender.crash.txt

    This is on the freshest of installs, I deleted every version of Blender I had and associated files and reinstalled from scratch before trying this out

  • Hi @Ace , thanks for the report. Maybe it's what @Moult suggested and that "access violation" is happening when trying to access a deleted IFC element, but indeed it's strange that it only happens in Windows.

    Could you provide the crash.txt?

  • @Ace what were you doing that triggered it? Has anyone managed to replicate it reliably? I find this a high priority bug to fix before it is possible to do another stable release.

  • Hey @cvillagrasa here is the crash.txt, I've just removed the file path since it's a bit sensitive

  • Thanks @Ace ! It seems that it's happening the second time "my" operator bpy.ops.bim.add_constr_type_instance() is called during the generation of construction type previews. Still no idea why it happens, and why it happens on Windows, though...

  • @Moult the process is:

    1) Start new Blender file
    2) Start new Ifc project (with library loaded)
    3) Hotkey onto the BIM tool (I set it on the quick shortcut so Q->B)
    4) Hotkey "N" to open the n panel, (to select the library item)
    5) it crashes

    I can't get it to crash today for some reason but this is the process

  • Thank you again @Ace . Yeah, step nº4 is when the construction type previews need to be generated and bpy.ops.bim.add_constr_type_instance() is called.
    @Moult asks: "is it an instacrash or is it a stall, not responding, and then crash?"

  • @cvillagrasa and @Moult It's an instant crash, always.

  • Proposal of a fix here:

    Please, wait until the PR is merged before testing ;)

  • Ok, already merged! please, report back if you keep experiencing crashes ;)

  • Spectacular, will check it out in the next release

  • Hey @cvillagrasa good news, it doesn't seem to crash anymore but this morning it just loaded 400 IfcBeams when I tried to open the tool ahahha

    and counting

  • Hi @Ace , thanks a lot for the comments as always.
    I also experienced this behaviour sometimes depending on the hardcoded retry interval. It looks like it depends on the machine, which is not acceptable and we'll need to think of something else.

  • It seems to only be happening on a single file so I think it must be something within it that is triggering this, although it is consistent, other files don't have the issue.
    I've attached a video of the error, just remove the .txt

  • Getting some odd behavior w/ Type tool...
    as of...
    Revision: d2836e07d5fef105d7234a144b7b52f87ef3f638 Author: Dion Moult <> Date: 9/28/2022 7:18:54 AM Message: Minor fix

  • Did it improve a bit with today's build?
    Important things are 1) that it doesn't crash and 2) that there are not tons of objects being created.
    A known issue at the moment is that behaviour is laggier than before.

  • Hey @cvillagrasa unfortunately I have not been able to activate todays blenderbim,
    once that is sorted will have a look

  • @Ace are you on Blender 3.3? As we've discovered in the OSArch Live Chat, that might be it.

  • @cvillagrasa I am using 3.3 and 3.2, Windows 10

  • @cvillagrasa I was able to activate it on 3.2 & 3.3
    the bug where it generates infinite beams was still there on both 3.3 and 3.2 haha

  • @Ace there's been a new build today with a fix by @cvillagrasa which has had good feedback from @theoryshaw ... try again?

  • Hey @Moult it seems to be working yay, and happy birthday ;)

    No more millions of IfcBeams or crashes on 3.3. or 3.2, thanks @cvillagrasa !

  • Wow is it Dion's birthday? 🥳

    Thanks @Ace , if you play with the multiviewer, you'll still get some odd behaviour, though. I'm finishing a new version that solves also that issue 😉

  • Ok, the version released today should fix that issue.
    When clicking on the browser button to see a multipreview (see circled operator below), the browser should work as expected.

    There are some things going on for the browser to update on each IfcElementType change from the dropdown list, which need to happen sequentially. I adjusted the delay from the timers so that it reliably works in my computer. I found out that shorter delays sometimes make the popup disappear, while of course longer delays feel laggier.

    Please, comment if you find the popup menu dissapear on your systems!

Sign In or Register to comment.